Instalar servidor de OpenMeetings en Ubuntu

Openmeetings instalación y funcionamiento 300x167 Instalar servidor de OpenMeetings en Ubuntu En este tutorial, verán y aprenderán la forma de instalar OpenMeetings en Ubuntu 9.10, configurar algunas funciones y como usarlas una vez su servidor esté en marcha. Sirve también para Ubuntu 10.04 o versiones anteriores. Una de las virtudes que hay que tener es la paciencia, ya que la instalación puede demorarse algún tiempo, pero si leen bien cada paso y ponen algo de sentido común, las cosas se facilitarán enormemente.

OpenMeetings (OM) es un servicio de Video Conferencia totalmente libre, con el cual se pueden realizar conferencias tanto públicas como privadas, entrevistas virtuales, chat en línea, creación fácil de salas, usuarios, reuniones programadas, y otras cuantas características. La instalación no es tan complicada y en esta guía verán que puede ser montada fácilmente en sus casas, y hacerla accesible desde cualquier lugar del mundo por medio de Internet.

Mi necesidad de uso de una herramienta de este tipo, nació al realizar un proyecto para la universidad en la que estudio, en donde se necesitaba un módulo virtual en donde los administrativos y docentes pudieran mantener reuniones sin moverse de sus sitios de trabajo, además de compartir documentos, archivos, páginas web, entre otras funciones.

En la web, encontré varios cientos de estas herramientas, pero la gran mayoría requieren pagos mensuales, o anuales y las que son gratuitas no cuentan con tantas características como se quisiera. Otra herramienta muy parecida, de muy buenas características y libre también, es dimdim, pero tiene varias limitaciones que no la hacen tan buena como OpenMeetings, lo digo porque probé ambas.

Instalación:

OpenMeetings, como la mayoría de los servicios, requieren de un equipo servidor que preste todas las funciones a los clientes que se conecten a el. Por ejemplo OpenMeetings puede ser integrada con Moodle, pero para hacerlo debemos contar con un servidor, al cual conectarse para que funcione. Y eso es lo que vamos a hacer en este tutorial.

Lo primero que hay que hacer es preparar el ubuntu para la instalación de los servicios y programas necesarios para poner en marcha nuestro servidor de OM.

Actualizamos los repositorios de ubuntu con los siguientes comandos:

  • sudo apt-get update
  • sudo apt-get upgrade

Instalamos la siguiente lista de programas (Hay algunos que requieren algunas configuraciones como contraseñas, nombres, etc, pero son fáciles de llenar… Si tienen alguna duda sobre alguno no olviden dejar un comentario).

Pueden copiar y pegar cada línea en la terminal y ejecutarla, o instalar uno por uno los programas.

  • sudo apt-get install -y java-package sun-java6-bin sun-java6-jdk sun-java6-jre mysql-server openoffice.org-writer openoffice.org-calc
  • sudo apt-get install openoffice.org-impress openoffice.org-draw openoffice.org-math imagemagick gs-gpl libart-2.0-2 libt1-5 zip unzip bzip2 subversion git-core checkinstall
  • sudo apt-get install texi2html libfaac-dev libfaad-dev libmp3lame-dev libsdl1.2-dev
  • sudo apt-get install libx11-dev libxfixes-dev libxvidcore-dev zlib1g-dev libogg-dev sox
  • sudo apt-get install libvorbis0a libvorbis-dev libgsm1 libgsm1-dev
  • sudo apt-get install libfaad2-0 libfaad-dev  flvtool2 lame swftools

No olviden los datos y contraseñas que ingresen al instalar los programas que así lo pidan, porque se necesitarán más tarde en el tutorial. La instalación de los anteriores servicios puede tardar un poco, así que hay que ser pacientes, al igual que en el transcurso de este tutorial.

Una vez terminado el anterior procedimiento, procedemos a bajar e instalar el ffmpeg, que nos servirá para grabar y codificar las grabaciones que se realizen en las videoconferencias o reuniones, cuando el sistema esté finalizado. Para esto lo primero que hay que hacer es bajar la última versión del programa desde www.ffmepg.org, (o bajar la última versión hasta la fecha de este artículo directamente). Por recomendación propia me parece mejor bajar todo al escritorio de Ubuntu y así trabajar más rápidamente.

Una vez descargado, nos dirigimos por la terminal hasta el sitio de descarga. En mi caso está en el escritorio por lo que para entrar uso el siguiente comando:

  • cd /home/ju4ns3/Escritorio/

Luego se descomprime el programa con el siguiente comando:

  • sudo tar -zxvf ffmpeg-0.6.1.tar.gz

Por último en el escritorio se creará la carpeta con el programa descomprimido y entramos a ella con el comando:

  • cd /home/ju4ns3/Escritorio/ffmpeg-0.6.1

Estando dentro, damos los siguientes comandos:

  • sudo ./configure (para entrar en el modo de configuración, puede demorarse algunos minutos)
  • sudo make (Compilación del programa, puede tomar algunos minutos)
  • sudo chekinstall (hacer más fácil la desinstalación, si se hace necesario luego)

Intalación y configuración de OpenMeetings

Ahora procederemos a instalar el OpenMeetings en nuestro equipo. Primero bajamos la última versión desde http://code.google.com/p/openmeetings/downloads/list (o descargar la última versión -1.5-RC1- hasta la fecha de publicación de ester artículo desde este enlace).

Luego ingresar al directorio de descargar, en este caso el escritorio “cd /home/ju4ns3/Escritorio” y descomprimirlo usando el siguiente comando:

  • sudo unzip openmeetings_1_5_rc1_r3393.zip

Luego procedemos a mover el directorio descomprimido a la carpeta opt así:

  • sudo mv red5 /opt/

Ahora vamos a configurar los permisos de los directorios y ficheros.

  • sudo chown -R nobody: /opt/red5                  (Configur el usuario nobody como propietario)
  • sudo chmod +x /opt/red5/*.sh                          (Dar permiso de ejecución)
  • sudo chmod +x /opt/red5/webapps/openmeetings/jod/*.sh (Dar permiso de ejecución)

Para hacer más fácil la configuración del servidor, podemos poner red5 y openoffice como servicios, que pueden ser fácilmente iniciados o detenidos con simples comandos en el terminal.

Para hacerlo creamos dos archivos de texto con los siguientes comandos:

  • sudo gedit /etc/init.d/red5
  • sudo gedit /etc/init.d/openoffice

En el primer archivo de texto (red5) copiamos y pegamos este código

En el segundo archivo de texto (openoffice) copiamos y pegamos este código

Luego de guardar ambos archivos, damos permisos de ejecución a cada uno.

  • sudo chmod +x /etc/init.d/red5
  • sudo chmod +x /etc/init.d/openoffice

Luego es bastante sencillo iniciar o detener cualquiera de los dos servicios. Obviamente ambos tienen que estar iniciados para que OpenMeetings funcione adecuadamente. Si se desea iniciar cualquiera de los dos servicios basta con ejecutar el siguiente comando:

  • sudo /etc/init.d/red start
  • sudo /etc/init.d/openoffice start

Si se desea detener, basta con cambiar start por stop y listo.

Ahora vamos a configurar la base de datos del servidor. Para estoy hay que recordar la contraseña que le dimos al instalar el Mysql en la primera parte del tutorial. La configuración de Mysql se puede hacer desde el administrador de la base de datos (si no sabes como acá hay varios comandos) o usando estos comandos en el terminal como se ha hecho a lo largo del manual.

  1. echo “CREATE USER openmeetings@localhost;” | mysql -u root -p (Creación del usuario)
  2. echo “CREATE DATABASE openmeetings DEFAULT CHARACTER SET ‘utf8′;” | mysql -u root -p (Creación de la base de datos)
  3. echo “GRANT ALL PRIVILEGES ON openmeetings.* TO ‘openmeetings’@’localhost’ IDENTIFIED BY ‘Tu contraseña‘ WITH GRANT OPTION;” | mysql -u root -p (Asignación de permisos y contraseña)
  4. echo “FLUSH PRIVILEGES;” | mysql -u root -p (Refrescamos los permisos)

En el paso 3, está de color azul la palabra contraseña, ya que debe ser cambiada por tu contraseña de Mysql antes de ejecutar el comando. Luego de hacer lo anterior abrimos el archivo de configuración:

  • sudo gedit /opt/red5/webapps/openmeetings/conf/hibernate.cfg.xml

Y en las líneas 12 y 13 cambiamos los datos por los nuestros, de forma que quede el usuario openmeetings y la contraseña de Mysql (borrosa en la imágen).

Configurar openmeetings1 Instalar servidor de OpenMeetings en Ubuntu

Una vez hecho esto, iniciamos los servidores red5 y opneoffice como se explicó más arriba.

Instalación del Servidor:

Este es el último paso de la instalación del servidor, Después de haber realizado sin problemas todo lo anterior, solo falta instalar el servidor. La forma de hacerlo es la siguiente:

Entramos a cualquier navegador (Firefox, Chrome….) y entramos a la siguiente dirección: http://localhost:5080/openmeetings/install Allí saldrá un aviso en donde dice que primero se deberán configurar varias cosas, pero si se fijan bien, son las que ya se han configurado, por lo que solo basta dar click más abajo donde dice Continue with STEP 1. Luego se abrirá una nueva ventana donde saldrán varis campos que se deben llenar. Basta con digitar los campos de Username, Userpass, Email, User Time Zone, Name y Default Language y luego dar click en Install. Si eres un usuario más experto podrás llenar varios o todos los campos que se necesitan. Pero para iniciar solo basta con los anteriores.

Al final saldrá un pantallazo como este y ya podrán entrar a la aplicación.

Instalación completa de OpenMeetings Instalar servidor de OpenMeetings en Ubuntu

Si se fijan, en la barra de direcciones del navegador, sale sudireccion:5080, este es el puerto que usa el OpenMeetings para funcionar.

Usar Openmeetings desde Internet

Con el anterior tutorial, podremos usar el openMeetings sin problemas en nuestra red local, es decir, de la forma en como se ha desarrollado este manual, se hace óptimo instalarlo en una empresa, o en un negocio en el que se necesite hacer reuniones virtuales desde cada departamento u oficina. Pero la forma más obvia y real de usar un programa de estos, es que sea visible en toda la red. Que yo pueda comunicarme con uno de mis empleados en USA desde Colombia por ejemplo, y aún así contar con todas las funciones y características como si se estuviera ejecutando localmente.

Para lograr esto, no hace falta configurar nada más en ninguna parte. Solo tenemos que darle acceso al Servidor desde internet. Para esto hay que abrir varios puertos necesarios para que cualquier persona en el mundo pueda acceder a nuestro servidor sin ningún tipo de problemas. Estos puertos son el 5080, 1935, 8088, y el 443. Lamentablemente no hay forma de explicar como abrir los puertos de un modem o router, ya que cada persona según su ISP cuenta con dispositivos totalmente diferentes. Para dejarles una muestra, En este enlace está como abrir puertos en un router SpeedTouch 585(i) v6 el cual es mi router para acceder a internet. Si no saben como hacerlo con sus propios dispositivos, basta con llamar a su proveedor de servicios de internet y pedir el favor de que lo hagan por ti. No tomará más de 10 minutos hacerlo.

Luego de tener los puertos abiertos, hay que tener en cuenta varias cosas. Muchas de las personas que tenemos acceso a internet, usamos direcciones IP de internet dinámicas, esto quiere decir que cada que apagamos y encendemos nuestro modem, la dirección posiblemente cambie. Lo contrario pasa con personas cuya IP es estática, ya que siempre es la misma y no hay problemas con eso. En cualquiera de los dos casos, si quieres que una persona en cualquier lugar del planeta se conecte a tu Servicio de OpenMeetings, tendrás que darle tu dirección IP Pública (no la privada). La forma de saber tu IP pública es muy sencilla, Basta con entrar a http://www.cualesmiip.com/ e inmediatamente te dirán cual es tu dirección.

Ahora basta con darle tu dirección seguida del puerto de OM a las personas que quieres tener conectadas a tu servicio. Un ejemplo sería 190.28.9.108:5080

Al enviar esta dirección a las personas que deseas conectar a tu servidor, lo único que tendrán que hacer es ponerla en un navegador cualquiera y entrar al servicio. Si tu dirección IP es dinámica, tendrás que mirar cada que quieras conectarte con varias personas, la IP con la que cuentas en ese momento y posteriormente enviarla.

Openmeetings instalación 300x198 Instalar servidor de OpenMeetings en Ubuntu

Openmeetings instalación y funcionamiento 300x167 Instalar servidor de OpenMeetings en Ubuntu

Esto es todo, y no duden en dejar todos sus comentarios, sugerencias, y dudas. En otro día haré el artículo de la integración de OpenMeetings con moodle para los que estén interesados.

Fuentes:

EDICIÓN –>

DIEGO, Uno de los usuarios que siguieron el manual, sobrepasó una serie de inconvenientes que tal ves muchos de ustedes tengan, por lo que recomiendo leer y aplicar las soluciones que nos brinda:

Para ser sinceros instalar el openmeetings y dejarlo bien me llevo más de un mes, investigar los errores, buscar. Abre reinstalado Ubuntu tantas veces q ni recuerdo.
La instalación la hice inicialmente en un vps de 384 MB de memoria, esta fue mi primer error ya q en conjunto red5, open office, openmeetinngs y demás programas ocuparon finalmente más de 750 MB de memoria, por ello al intentar correr java me aparecía el siguiente error:
Error occurred during initialization of VM
Could not reserve enough space for object heap
Could not create the Java virtual machine.
Cambie de vps a uno de 2ghz de memoria y 4000 mhz de procesador.
Seguí la guía de ju4ns3, pero el Linux Ubuntu 10.04 q tengo es server, he aquí el inconveniente, muchos de los repositorios de la versión de escritorio no están presentes en el server.
Primero modifique los repositorios así :
Edite el archivo sources.list : etc/apt/sourses.list
Al no poder instalar java como dice esta guía tuve q agregar el repositorio de canonical(ojo esto es para la versión 10.04 lucid), agrega este:
deb http://archive.canonical.com/ lucid partner
apt-get update
apt-get install sun-java6-jdk
y luego los siguientes(están en la página oficial de Ubuntu),por q no encontraba por ejemplo libxml2-devel, libfaac-dev.
Repositorios extras Ubuntu lucid(10.04)
deb http://archive.ubuntu.com/ubuntu lucid universemultiverse
deb-src http://archive.ubuntu.com/ubuntu lucid universemultiverse

deb http://us.archive.ubuntu.com/ubuntu/ lucid universe
deb-src http://us.archive.ubuntu.com/ubuntu/ lucid universe
deb http://us.archive.ubuntu.com/ubuntu/ lucid-updatesuniverse
deb-src http://us.archive.ubuntu.com/ubuntu/ lucid-updatesuniverse

deb http://us.archive.ubuntu.com/ubuntu/ lucid multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ lucid multiverse
deb http://us.archive.ubuntu.com/ubuntu/ lucid-updatesmultiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ lucid-updatesmultiverse

deb http://security.ubuntu.com/ubuntu lucid-securityuniverse
deb-src http://security.ubuntu.com/ubuntu lucid-securityuniverse
deb http://security.ubuntu.com/ubuntu lucid-security multiverse
deb-src http://security.ubuntu.com/ubuntu lucid-security multiverse
Con esto instalo casi todo, menos una librería q no recuerdo bien pero fue reemplazada por otra más nueva.
como no encontraba libmp3lame-dev (E: Couldn’t find package libmp3lame-dev), para ello hice lo siguiente:
# wget http://ufpr.dl.sourceforge.net/project/lame/lame/3.97/lame-3.97.tar.gz
# tar -xzvf lame-3.97.tar.gz
# cd lame-3.97
# ./configure
# make
# make install
La base de datos la cree asi :
mysql -p -u root
mysql> CREATE DATABASE openmeetings DEFAULT CHARACTER SET ‘utf8?;

GRANT ALL PRIVILEGES ON openmeetings.* TO ‘openmeetings’@’localhost’ IDENTIFIED BY ‘clave’ WITH GRANT OPTION;
mysql> quit
Todo lo demás lo hice como esta en la guía.
No recuerdo otro inconveniente, finalmente instale moodle 2.02, ahí tuve otros líos pero salí airoso. Ahora los tengo a los dos integrados.
Gracias por la ayuda.
Saludos.

 


Puedes seguir los comentarios de esta entrada a través de RSS 2.0 Usted puede dejar un comentario, o trackback.

Acerda de Juan Sebastián

Ingeniero de Sistemas y Telecomunicaciones de la Universidad de Manizales (Colombia) con énfasis en Redes y Seguridad Informática. Creador y administrador de ComuSOFT.com y apasionado del mundo de las redes de telecomunicaciones, el Software libre, Linux y la Seguridad de la Información. Actualmente me desempeño como Help Desk Engineer en una importante Multinacional de Seguridad Informática en Latino América. En lo que pueda colaborarte, lo haré con gusto!
Escribe un Comentario

71 Respuestas

  • Pingback: Bitacoras.com

  • Pingback: Instalar y Configurar un servidor OpenMeetings en Ubuntu

  • diego says:

    MUy bueno tu post, te felicito….. pero quisiera que me ayudaras a poner le openmeeting para verlo por internet,

    tengo un modem huawei smart MT880 y no se como hacer para poner una direccion de dominio y esta me lo redireccione hasta llegar a mi PC donde esta instalado el openmeetings, te agradeceria si puesieras un tutorial paso a paso asi como este, pues ya he intentado poner mi PC de forma online y solamente he llegado hasta entrar a la pagina de configuracion mi modem y no me llega hasta mi PC.

    Gracias men se que esta duda la pueden tener muchas mas personas.

    • ju4ns3 says:

      Hola diego, con gusto te puedo ayudar con tu problema… lo unico que hay que hacer para poder acceder desde internet a tu servidor de openmeetings es usar la dirección pública que te da tu ISP, la cual la puedes averiguar muy facilmente en http://www.cualesmiip.com/ .. y segun veo tu ya tienes acceso a tu modem, por lo que te queda mas facil abrir los puertos desde alli. Una vez abiertos estos puertos que describo en el tutorial, entrando por la direccion publica que te arroja la página cualesmiip.com seguida del puerto 5080 puedes hacer tus pruebas.

      Aca te dejo una posible guia q te puede servir para abrir los puertos en tu modem http://www.taringa.net/posts/info/1834697/Como-abrir-los-puertos-del-SmartAX-MT880-Huawei.html

      Si te funciona me avisas para armar un tutorial en el foro de nuestra página y así ayudarte y ayudar a todos lo que lo necesiten…. si aun sigues con dudas, no dudes en volver a comentar.. estamos para ayudar! un saludo

  • Josue says:

    Que onda. esta excelente tuy post. solo que tengo una serie de problemas, cuando intento instalar la primer linea que marcas aqui en tu post despues de hacer el “upgrade” me marca un error me dice que no encuentra el paquete sun-java6-bin

    • ju4ns3 says:

      Hola josue… Es muy extraño que te salga el error puesto que acabo de probarlo y funciona sin problemas… prueba de nuevo intentando con los comandos update y upgrade o fijate si ya tienes una versión del java instalada en tu PC. Trata de continuar con la instalación y si no te funciona, puedes volver a escribirme y profundizar un poco más para ayudarte.

  • Josue says:

    Hola de nuevo.. el problema del jdk ya quedo solucionado, ahora tengo otro problema, yo tengo instalado un servidor xampp en mi ubuntu 10.04, entonces al estar haciendo los pasos de tu post omiti lo que es la instalacion de mysql dado de que el xampp ya tiene mysql, entonces eso lo omiti.
    1.- Cuando intento iniciar el servicio de “sudo /etc/init.d/openoffice start” no hay ningun problema pero cuando le doy “sudo /etc/init.d/openoffice stop ” me marca “Stopping OpenOffice headless server” y despues me manda esto “soffice:proceso no encontrado”

    2.- Mi sugundo problema es que le segui asi con la instalacion y cuando llego a donde ingresamos “http://mi-ip:5080/openmeetings/install si me aparece la pagina donde debo ingrasar los datos de usuario correo etc etc.. pero cuando le doy que pase a la segunda parte o segundo paso ya no carga la página se queda en blanco.. :S !!!! Y si le pongo en el navegador “http://mi-ip:5080/openmeetings/ me aparace un mensaje de cargando que dice

    “Autoconnect
    NetCnnection.Call.Failed
    rtmpt://mi-ip:8088/openmeetings/hibernate”

    y despues de que aparece este mensaje y una barrita de cargando, me manda un mensaje de error!!!!

    Espero tu pronta respuesta y que me puedas ayudar ya que me urge levantar este servidor para despues integrarlo con la plataforma moodle ya que el servicio de dimdim para videoconferencias en moodle ya no es libre..

    Saludos!!

  • Josue says:

    hoo sii me faltaba otra cosa!!! aunque no creo que esto sea la causa de mis problemas.

    cuando estaba instalando todos los paquetes que solicitas al principio los instale, menos estos paquetes “sudo apt-get install libfaad2-0 libfaad2-dev flvtool2 lame swftools” porque cuando ingresaba esa instruccion me manda el siguiente error:

    “Leyendo lista de paquetes….Hecho
    Creadno arbol de dependencias
    Leyendo la informacion de estado…. Hecho
    El paquete libfaad2-0 no está disponible, pero algún otro paquete hacer referencia
    a él. Esto puede significar que el paquete falta, está obsoleto o sólo se
    encuentra disponible desde alguna otra fuente
    Sin embargo, los siguientes paquetes lo reemplazan:
    libfaad2
    E: El paquete libfaad2-0 no tiene candidato para su instalacion”

    Cres que los problemas que te mencione sean por falta de estos paquetes!!! ???? yo pienso que no… pero no se tu que pienses!!!

    saludos

  • ju4ns3 says:

    Hola Josue:

    Varias cosas para tus problemas:

    1. No se en que grado pueda afectar, pero mi instalación la hice en ubuntu 9.10 y no en el 10.04 aunque no creo que haya cambios si me he dado cuenta de algo y es que al momento de instalar algunos paquetes, sucede lo que te pasa a ti con el libfaad2-0 que el mismo sistema te dice por cual fue reemplazado “libfaad2″. Yo te recomiendo entonces que al momento de instalar cualquier paquete mires si el sistema te da la opción y solo la cambias por el que te den y muy seguramente se instalará.

    2. En cuanto al OpenOffice creo que si el servicio cuando lo iniciaste funciona bien, aun no lo detengas mientras miramos si el resto funciona bien, y así puedo buscar un poco mas de información del error ya que es desconocido para mi. De todas formas verifica bien los códigos de cuando se convirtió en un servicio, los permisos etc.

    3. Puede que cuando le des install no te pase de página por las librerías que te faltan instalar, entonces te recomiendo que trates de instalar todas porque por algo se marcan como necesarias.

    4. Si ya tenías Mysql instalado, fijate en las partes donde se piden nombres de usuario y contraseña, que todo coincida con la instalación y con lo que tu ya tenías instalado.

    Mi objetivo es que todo quede funcional y te sirva para lo que quieres… si después de esto nada te sirve, pues intentaré entonces brindarte mas ayuda buscando y mirando que puede estar pasando. Podemos abrir un tema en el foro de esta página para compartirlo con más usuarios. Un saludo!!

    • Josue says:

      que tal.. gracias por tu pronta respuesta!!

      mira estuve checando esta otra página http://code.google.com/p/openmeetings/source/browse/wiki/OpenmeetingsEnUbuntu.wiki?r=3632 y al parecer con estos paquetes donde me pide las librerias que me faltaban ya los instale. ahorita volvi a ir a htt://localhost:5080/openmeetings/install y llene solo algunso datos y le di install y aun sigue sin funcionar =S au podra ser mi error!!??

      intentare empezar de nuevo pero con unas maquinas virtuales para ver si estuve mal desde el inicio!!

      pero ahora lo hare sin tener xampp solo instalare todos los paquetes que me pides y lo hare en ubuntu 9.04

      saludos!!!

      espero resolver esto pronto me urge!!!

      • ju4ns3 says:

        Me parece bien, estaré atento a cualquier cosa!

        • Josue says:

          Hola que tal ju4ns3!!

          Recuerdas que te dije que lo intentaria instalar con los pasos que tudices en una maquina virtual?? Pues hoo sorpresa asi si me funciono!!

          Pero lo que pasa es que yo tengo instalado el xampp, y lo que hice fue instalar el ffmp… ect y cuando desempaqueto openmeetings lo desempaqueto en la siguiente direccion /opt/lampp/red5
          y cuando creo la base de datos y el usuario y privilegios todo va bien hasta ahi, pero cuando me paso al navegadro me vuelve a pasar lo mismo!!!! no pasa al paso 2!!! espero que me puedas ayudar!!! necesito integrar red5 (openmeetings) con xampp para posteriormente integrar openmeetings con moodle!!!

          Espero tu respuesta!!!!

          sal2!!!

          • ju4ns3 says:

            Josue que tal!.. tengo una pregunta antes de poder buscar una solución mejor.. y que bueno que por lo menos funcionó en la máquina virtual.. por lo menos el procedimiento está bien…. Lo que no entiendo es porqué descomprimes el OM dentro del directorio “lampp” y no solo dentro de /opt .. es decir debería quedar /opt/red5 y no /opt/lampp/red5.. Puede que esto ocasione algún error porque quizás hay alguna parte donde se llame la ruta (No estoy seguro te aclaro!!)… pero sería cuestión de mirar más detalladamente…

            Cualquier cosa avísame y pues es comprensible que la instalación se complique un poco cuando se integran más servicios y me interesa aprender también. Saluds

  • Josue says:

    quet tal!! gracias por tu respuesta!!

    ya lo hice varias veces asi y sigue igual!!

    y cuando lo cambie a /opt/lamp/ modifique el archivo /etc/init./red5 ya que este archivo manda llamar a red5 y ahi hay una parte donde dice /opt/red5 y yo lo cambie a /opt/lampp/red5 pero aun asi sigue sin funcionar!!

    Que podra ser!

    • ju4ns3 says:

      josue…pues la verdad pueden ser muchas cosas las que pasen… lo que te puedo recomendar es q repases paso por paso desde el inicio la instalación, si depronto te faltó algún paquete por instalar o se omitió cualquier cosita por más pequeña que sea…. Si puedes compara lo que hiciste en la máquina virtual con lo que tienes en tu Ubuntu.

      también para descartar errores en la BD te puedo recomendar que cambies de usuario y contraseña en tu base de datos, por otros nuevos, en los pasos de la instalación del OM:

      /***********************************************************/
      echo “CREATE USER openmeetings@localhost;” | mysql -u root -p (Creación del usuario)
      echo “CREATE DATABASE openmeetings DEFAULT CHARACTER SET ‘utf8?;” | mysql -u root -p (Creación de la base de datos)
      echo “GRANT ALL PRIVILEGES ON openmeetings.* TO ‘openmeetings’@’localhost’ IDENTIFIED BY ‘Tu contraseña‘ WITH GRANT OPTION;” | mysql -u root -p (Asignación de permisos y contraseña)
      echo “FLUSH PRIVILEGES;” | mysql -u root -p (Refrescamos los permisos)
      En el paso 3, está de color azul la palabra contraseña, ya que debe ser cambiada por tu contraseña de Mysql antes de ejecutar el comando. Luego de hacer lo anterior abrimos el archivo de configuración:

      sudo gedit /opt/red5/webapps/openmeetings/conf/hibernate.cfg.xml
      Y en las líneas 12 y 13 cambiamos los datos por los nuestros, de forma que quede el usuario openmeetings y la contraseña de Mysql (borrosa en la

      /*************************************************************************/

      Prueba con otro usuario nuevo que tu crees…

      La mejor forma de mirar realmente que error te sale es mirando en la consola un log de errores/eventos … no recuerdo muy bien pero creo que el comando es $ sudo tail -f /var/log/all.log al abrir el log, intenta de nuevo generar el error y mirar en la consola donde está el fallo

      yo trataré de leer toda la instalación haber que más puede ser…y si algo comento… Un saludo!

  • Josue says:

    ok hare eso que me dices!!
    espero encontrar una solucion, si no la unica solucion que yo le veo es parar el servicio de mysql del xampp e instalar mysql-server aparte y mudar todas mis bases de datos creadas en xampp al nuevo mysqlserver … ya que con el mysql-server instalado aparte si me funciona..

    hoo si,, en tus pasos de la instalacion vi que te falta un parametro, bueno ese parametro yo lo vi en la pagina que te comente en un post anterior , ese paso es el siguiente:
    $ sudo update-rc.d red5 defaults
    $ sudo update-rc.d openoffice defaults

    yo estos pasos si los realizo, y espero que esto no sea lo que me esta ocacionando el problema.

    tampoco puede ser las versiones de ubuntu porque cuando lo hice en la maquina virtual funciono con ubutnu 9.10 y tambien con la 10.04

    estare comentando lo que me pueda surgir

    salu2

    • ju4ns3 says:

      Perfecto, estudia bien lo del log de eventos y errores porque eso me ha sacado de varios problemas… cualquier cosa también te avisaré

      • J0su3||| says:

        hol de nuevo ju4ns3!!

        con los pasos qur tu tienes para instalar este servidor no puedo instalar la ultima linea ocea la siguiente:

        libfaad2-0 libfaad2-dev flvtool2 lame swftools

        me manda el siguiente error;:

        moodle@moodle-desktop:~$ sudo apt-get install libfaad2-0 libfaad2-dev flvtool2 lame swftools
        Leyendo lista de paquetes… Hecho
        Creando árbol de dependencias
        Leyendo la información de estado… Hecho
        El paquete libfaad2-0 no está disponible, pero algún otro paquete hace referencia
        a él. Esto puede significar que el paquete falta, está obsoleto o sólo se
        encuentra disponible desde alguna otra fuente
        Sin embargo, los siguientes paquetes lo reemplazan:
        libfaad2
        E: El paquete libfaad2-0 no tiene candidato para su instalación
        moodle@moodle-desktop:~$

        y con los pasos de la pagina que te hice referencia no me marca ese error todo me lo instala sin ningun problema!!

        por que sera que con tus pasos no puedo instalar esos ultimos paquetes!!

        • ju4ns3 says:

          La razón por la que con mis códigos te sale error es porque ya NO se llama “libfaad2-0″ sinó libfaad2 … solo debes cambiar en la línea de instalación eso y ya te funciona… de todas formas te agradezco y ya lo voy a cambiar en el post!!!
          salud2

          • J0su3||| says:

            me sigue marcando el error:

            moodle@moodle-desktop:~$ sudo apt-get install libfaad2 libfaad2-dev flvtool2 lame swftools
            [sudo] password for moodle:
            Leyendo lista de paquetes… Hecho
            Creando árbol de dependencias
            Leyendo la información de estado… Hecho
            libfaad2 ya está en su versión más reciente.
            fijado libfaad2 como instalado manualmente.
            El paquete libfaad2-dev no está disponible, pero algún otro paquete hace referencia
            a él. Esto puede significar que el paquete falta, está obsoleto o sólo se
            encuentra disponible desde alguna otra fuente
            Sin embargo, los siguientes paquetes lo reemplazan:
            libfaad-dev
            E: El paquete libfaad2-dev no tiene candidato para su instalación

          • ju4ns3 says:

            Bien, entonces muy seguramente el paquete libfaad2 ya incluyo el “-dev” entonces omítelo. Solo pon:

            sudo apt-get install libfaad2 flvtool2 lame swftools

  • diego says:

    Hola, tengo un problema, por que no puedo instalar java-package sun-java6-bin sun-java6-jdk sun-java6-jre, no los encuentra, busque por todos lados, sin suerte, en la pagina de java no hay un link para bajarlo directamente ya q tengo un vps sin modo grafico solo.
    donde podre conseguirlas?
    Gracias.
    Saludos

    • ju4ns3 says:

      Que tal Diego, me podrías decir o mejor, copiar lo que te sale en la consola cuando pones el comando de instalacion de los paquetes??? tal vez alguno de los repositorios cambió… un saludo

      • diego says:

        lo q aparece es lo siguiente:
        Reading package lists… Done
        Building dependency tree
        Reading state information… Done
        E: Couldn’t find package java-package

        gracias por responder tan rapido.
        saludos

  • ju4ns3 says:

    Diego, creo que este error te sale porque no has actualizado los repositorios de ubuntu.. Ejecutaste los comandos “sudo apt-get update” y “sudo apt-get upgrade” ??

    Un saludo

    • diego says:

      Hola luego de instalar todos los programas, y seguir todos los pasos inicio red5, el cual da el ok, el problema es con java aparece lo siguiente:

      Error occurred during initialization of VM
      Could not reserve enough space for object heap
      Could not create the Java virtual machine.

      puede ser por q mi vps tiene 384 mb de ram, es poca memoria? o es un problema de configuracion.
      Instale java-1.6.o-openjdk.

      • ju4ns3 says:

        A simple vista pareciera un problema de espacio por el cual no se puede crear la maquina virtual java y pues al conocer la ram probablemente sea un impedimento… pero es un error un poco desconocido, voy a buscar más información sobre ese error para poder ayudarte un poco más

  • julian Rodriguez says:

    Que tal, con esta herramienta es posible transmitir vídeo en tiempo real? Espero me pueda ayudar. Aun no he probado la instalación pero seguro lo hago
    Saludos

  • diego says:

    hola, solucione lo de java pero no puedo instalar libfaac-dev , libmp3lame-dev, lame
    busque pero no encontre nada para solucionarlo.
    mi sourses.list es esta:

    deb http://archive.ubuntu.com/ubuntu lucid main restricted universe
    deb http://archive.ubuntu.com/ubuntu lucid-updates main restricted universe
    deb http://archive.ubuntu.com/ubuntu lucid-security main restricted universe
    deb http://archive.canonical.com/ lucid partner

    instale todo lo demas, pero cuando le doy en instalar, al opemmeetings, se queda en el paso uno.
    Gracias por tu atencion.

  • julian says:

    Que tal me puedes ayudar por favor.
    Desde un principio me marca error apartir de aqui
    —————————————————————————————————————————————
    sudo apt-get install -y java-package sun-java6-bin sun-java6-jdk sun-java6-jre mysql-server openoffice.org-writer openoffice.org-calc

    El error es
    E: No se ha podido localizar el paquete java-package
    E: No se ha podido localizar el paquete sun-java6-bin
    E: El paquete «sun-java6-jdk» no tiene candidato de instalación
    E: El paquete «sun-java6-jre» no tiene candidato de instalación
    Espero me puedas ayudar

  • julian says:

    Ingeniero por fin logre instalar Openmeeting la instalacion es de mucha dedicacion.
    Muy buen tutorial super!
    Gracias

  • diego says:

    Gracias por la ayuda logre instalar openmeetings en un servidor virtual(vps) con ubuntu server 10.04, y tambien moodle y los pude integrar. luego les paso los problemas q tuve ycomo los solucione.
    Saludos

    • Hola me gustaría inslalar OpenMeetings diego en mi VPS, pero me estoy enfrentando los mismos problemas que usted fijó en la instalación de red tutorial me podría ayudar?
      primero que no se puede instalar Java
      entonces no puedo instalar openoffice
      me ayude por favor
      mi msn es luka_mussoi@hotmail.com

      Soy brasileña

      • Un saludo a todos, Acabo de revisar los problemas que han tenido algunos con su instalación y los acabo de instalar todos en mi Ubuntu 9.10. Corregí algunos que cambiaron desde los repositorios y aclaré otros que estaban un poco confusos. Acabo de instarlos todos sin ningún problema en mi ubuntu y espero puedan solucionarlo ustedes también. Los códigos cambiados son los del inicio del tutorial:

        – sudo apt-get install -y java-package sun-java6-bin sun-java6-jdk sun-java6-jre mysql-server openoffice.org-writer openoffice.org-calc

        – sudo apt-get install openoffice.org-impress openoffice.org-draw openoffice.org-math imagemagick gs-gpl libart-2.0-2 libt1-5 zip unzip bzip2 subversion git-core checkinstall

        – sudo apt-get install texi2html libfaac-dev libfaad-dev libmp3lame-dev libsdl1.2-dev

        – sudo apt-get install libx11-dev libxfixes-dev libxvidcore-dev zlib1g-dev libogg-dev sox

        – sudo apt-get install libvorbis0a libvorbis-dev libgsm1 libgsm1-dev

        – sudo apt-get install libfaad2-0 libfaad-dev flvtool2 lame swftools

        Si llegan a tener más problemas porfavor no duden en dejar su comentario.
        Salu2!!

  • @julian, me alegro que el tutorial fuera de exitoso y hayas podido instalarlo.. y si es de mucha paciencia!

    @diego, Me alegro que mi tutorial te sirviera, y sería muy bueno compartir lo que dices en cuanto los problemas y las soluciones. Apenas puedas se publicarán inmediatamente a tu nombre. Un saludo

  • DIEGO says:

    Para ser sinceros instalar el openmeetings y dejarlo bien me llevo más de un mes, investigar los errores, buscar. Abre reinstalado Ubuntu tantas veces q ni recuerdo.
    La instalación la hice inicialmente en un vps de 384 MB de memoria, esta fue mi primer error ya q en conjunto red5, open office, openmeetinngs y demás programas ocuparon finalmente más de 750 MB de memoria, por ello al intentar correr java me aparecía el siguiente error:
    Error occurred during initialization of VM
    Could not reserve enough space for object heap
    Could not create the Java virtual machine.
    Cambie de vps a uno de 2ghz de memoria y 4000 mhz de procesador.
    Seguí la guía de ju4ns3, pero el Linux Ubuntu 10.04 q tengo es server, he aquí el inconveniente, muchos de los repositorios de la versión de escritorio no están presentes en el server.
    Primero modifique los repositorios así :
    Edite el archivo sources.list : etc/apt/sourses.list
    Al no poder instalar java como dice esta guía tuve q agregar el repositorio de canonical(ojo esto es para la versión 10.04 lucid), agrega este:
    deb http://archive.canonical.com/ lucid partner
    apt-get update
    apt-get install sun-java6-jdk
    y luego los siguientes(están en la página oficial de Ubuntu),por q no encontraba por ejemplo libxml2-devel, libfaac-dev.
    Repositorios extras Ubuntu lucid(10.04)
    deb http://archive.ubuntu.com/ubuntu lucid universemultiverse
    deb-src http://archive.ubuntu.com/ubuntu lucid universemultiverse

    deb http://us.archive.ubuntu.com/ubuntu/ lucid universe
    deb-src http://us.archive.ubuntu.com/ubuntu/ lucid universe
    deb http://us.archive.ubuntu.com/ubuntu/ lucid-updatesuniverse
    deb-src http://us.archive.ubuntu.com/ubuntu/ lucid-updatesuniverse

    deb http://us.archive.ubuntu.com/ubuntu/ lucid multiverse
    deb-src http://us.archive.ubuntu.com/ubuntu/ lucid multiverse
    deb http://us.archive.ubuntu.com/ubuntu/ lucid-updatesmultiverse
    deb-src http://us.archive.ubuntu.com/ubuntu/ lucid-updatesmultiverse

    deb http://security.ubuntu.com/ubuntu lucid-securityuniverse
    deb-src http://security.ubuntu.com/ubuntu lucid-securityuniverse
    deb http://security.ubuntu.com/ubuntu lucid-security multiverse
    deb-src http://security.ubuntu.com/ubuntu lucid-security multiverse
    Con esto instalo casi todo, menos una librería q no recuerdo bien pero fue reemplazada por otra más nueva.
    como no encontraba libmp3lame-dev (E: Couldn’t find package libmp3lame-dev), para ello hice lo siguiente:
    # wget http://ufpr.dl.sourceforge.net/project/lame/lame/3.97/lame-3.97.tar.gz
    # tar -xzvf lame-3.97.tar.gz
    # cd lame-3.97
    # ./configure
    # make
    # make install
    La base de datos la cree asi :
    mysql -p -u root
    mysql> CREATE DATABASE openmeetings DEFAULT CHARACTER SET ‘utf8′;

    GRANT ALL PRIVILEGES ON openmeetings.* TO ‘openmeetings’@’localhost’ IDENTIFIED BY ‘clave’ WITH GRANT OPTION;
    mysql> quit
    Todo lo demás lo hice como esta en la guía.
    No recuerdo otro inconveniente, finalmente instale moodle 2.02, ahí tuve otros líos pero salí airoso. Ahora los tengo a los dos integrados.
    Gracias por la ayuda.
    Saludos.

  • toquimix says:

    Hola estoy en la instalacion y estoy en este paso
    apt-get install libfaad2-0 libfaad-dev flvtool2 lame swftools
    y me devuelve el siguien te error
    apt-get install libfaad2 flvtool2 lame swftools
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    libfaad2 is already the newest version.
    libfaad2 set to manually installed.
    E: Couldn’t find package swftools
    que podria ser ayudenme

    • Según lo que te marca el error aparece como si no estuvieran los repositorios completos ya que no encuentra el paquete del swftools… estás haciendo la instalación como super usuario???

      Intenta de nuevo si no es así y trata solo de instalar el swftools sin nada mas. Si no funciona habría que buscar el repositorio o tratar de instalarlo usando Synaptics

  • Jose says:

    Que tal un saludo. Me puede ayudar Ingeniero. Instale Openmeetings en Ubuntu y todo salio bien, lo unico que causa problema es que al subir algun archivo a la pizarra me aparece una imagen que dice DELETE y no me muestra el documento word o power point.
    Espero que me pueda ayudar
    Saludos

  • Jose que tal!… fíjate si las herramientas de swftools quedaron bien instaladas, y si en tu navegador cuentas con las últimas versiones de flash, avísame como te va!

  • julian says:

    Que tal Juan Sebastian, un favor me puede indicar que comando es el correcto para instalar swftools por favor me pasa lo mismo aparece DELETED

    Saludos gracias

  • Julian, lo puedes hacer con este comando:

    sudo apt-get install libfaad2-0 libfaad-dev flvtool2 lame swftools

    Espero se solucione el problema, saludos!

  • Ivan says:

    No logro pasar del paso 1 en el navegador, relleno solo los camos sugeridos, pero no pasa de alli.

  • Hola Ivan, si quieres puedes ser un poco más específico y brindar detalles un poco más técnicos para poder saber donde está el error.. saludos!

  • Jose says:

    Que tal un saludo. tengo instalado swftools pero persiste el problema DELETED en mi pizarracuando subo presentacion power point, me pueden ayudar por favor. Tambien tengo openoffice pero no se muestra

    Gracias

  • Jose voy a buscar información respecto a este problema y te responderé lo más pronto posible. Salu2

  • Jorge Castro says:

    un saludo
    tengo un problema a la hora de iniciar el openmeetings me aparece este error “netconecction.connect.closed

    rmtp://localhost:8088/openmeetings/hibernate

    agradesco una pronta ayuda

    ubuntu 10.04 pero no es server hay algun problema

  • Jose says:

    Gracias Juan Sebastian, la verdad muchas gracias, ademas no abre openoffice de la forma normal en mi pc, eso tiene que ver que no se muestren los archivos en la pizarra de openmeetings? existe algun comando para poder corregir el error?

  • Jose que tal… si no te funciona el openoffice es bastante probable que ese sea el error. Intenta reinstalando el openoffice con este comando sudo apt-get install openoffice.org

    Si no te funciona descárgalo desde el sitio oficial y sigue las instrucciones

    Saludos!

  • Pingback: Descargar Ubuntu 11.04 Gratis - ComuSOFT.com

  • Emilio says:

    Hola, he instalado el openmeeting en Ubuntu desde live DVD, me va bien, pero tengo problemas con el sonido,
    cuando ha se conectan 3 o mas usuarios se acopla el sonido y se oye un pitido constante que es horroroso. que puedo hacer ? es del lado servidor o es del lado cliente?

    Otra cosa para poder modificar el diseño del cliente-navegador (personalizarlo) que debo hacer ??

    Gracias de antemano

  • Hola Emilio, lo que describes me pasó en algún momento a mi, pero el problema fue que mientras lo instalaba y le hacía pruebas, lo hacía con más pcs en el mismo lugar y ese sonido me hacía detener el servidor. Cuando lo probé vía internet con más usuarios el problema desapareció. De todas formas mira que opciones de audio tienes o intenta bajar el volumen del micrófono, o mejor aún, usar auriculares.

    En cuanto al diseño, no tengo información sobre esto, habría que buscar si hay temas o templates para diseñar o mejorar el aspecto del cliente, pero dudo que sea posible, ya sería una cuestión más de personalización propia buscando archivos o algo así.

    salu2!

  • Emilio says:

    Gracias, Juan Sebastian.
    el tema del sonido es como tu dices, con handset funciona bastante mejor.
    Si encuentro algo referente al diseño, lo comentaré, pero es un tema que me interesa.
    Otra cosa, como puedo ver que versiones tengo instaladas en el servidor, de openmeeting, como de red5,, OpenOffice, ImageMagick y GhostScript, SWFTools , FFMpeg y SoX ?
    gracias de antemano

    • Hola Emilio, para saber la versión de un paquete que tengas instalado en tu Linux se hace con el comando

      dpkg -s “paquete” | grep Version

      Solo con el dpkg -s “paquete” te muestra la versión pero junto con muchos otros datos, haciendo el grep Version solo te muestra la línea de la versión. Espero te sea de mucha ayuda :)

  • Emilio says:

    Gracias. Y para ver la version de red5 y openmeeting que hay instalada ? Sabes alguna url donde pueda ver la ultima version de openmeeting y sus dependencias de version con todos los paquetes que necesita (OpenOffices, SoX, ….etc) ?
    De verdad , gracias de antemano por tu ayuda

  • Emilio says:

    Por fa, como puedo ver que versión xx RCx r3…. tengo instalada en el servidor ?
    Gracias de antemano

  • Emilio que tal, con el comando que te di no te funcionó??? tiene que salirte la versión que tienes instalada de cualquier servicio, paquete o programa, trata de nuevo. Con respecto a la URL con las dependencias, el único sitio donde puede estar es en el oficial pero no tengo la certeza, visítalo http://code.google.com/p/openmeetings/

    Salu2!

  • Emilio says:

    Hola Juan,
    si que me funciona, pero con esta instrucción no me sale la version de OpenMeeting, ni de red5 …!!! como puedo saberlo, exactamente la revision que hay instalada de Openmeeting?

    salu2

  • Emilio says:

    Hola Juan,
    si que me funciona, pero con esta instrucción no me sale la version de OpenMeeting, ni de red5 …!!! como puedo saberlo, exactamente la revision que hay instalada de Openmeeting?

    salu2

    • Prueba revisando cuando abres el servidor de OpenMettings en la sección de Ayuda o Acerca de, allí deberías poder ver la versión del software que se está ejecutando :)

      • Emilio says:

        Hola Juan,
        no veo en el servidor de OpenMetting la seccion de Ayuda o Acerca de … no se, voy un poco perdido para ver la version de Openmeeting que hay instalada en el servidor, ya que necesito ir actualizando la version … Gracias

        • Emilio trataré de hacer una instalación rápida esta semana del OpenMeetings para poder ayudarte, ya que no lo tengo instalado actualmente. Sin embargo si descargaste la última versión del OpenMeetings de la página oficial, la versión es la que obviamente bajaste, y solo es estar pendientes del sitio oficial para saber cuando hay una nueva versión. Saludos!

  • Emilio says:

    Gracias Juan, pero es que instalé el Meeting Live DVD y ya venia con los paquetes instalados, con lo que no se que version tengo de red5 & OpenMeeting.???
    Gracias

    • Hola Emilio, en respuesta a tu pregunta me queda por decirte que revises primero que todo los archivos de instalación que se encuentran en tu DVD, todos los servicios de Linux tienen en sus archivos un README o un archivo que dice INSTALLATION o algún otro que ofrece información sobre el servicio en sí. Revisa bien estas carpetas en busca de la información que necesitas. En caso de no encontrar las versiones que has instalado te recomiendo entonces comunicarte con el equipo de desarrolladores del openmeetings:

      http://code.google.com/p/openmeetings/wiki/Jobs

      Allí hay varios correos e inluso Skype de los desarrolladores, a los cuales les puedes trasladar la duda. Ellos sin duda pueden decirte exactamente que hacer porque son desarrolladores altamente experimentados. Cuéntame como te va! Saludos!

  • Emilio says:

    Gracias, lo intentaré comunicandome con el equipo de desarrolladores de openmeeting
    Te comentaré !

  • Andres Diaz says:

    Hola Juan
    realice todos los pasos de el tuto, pero cuando intento subir el servicio de openoffice me generan varias errores:

    /etc/init.d/openoffice: 2: /etc/init.d/openoffice: penoffice.org: not found
    Starting OpenOffice headless server
    root@videocoopetrol:~# Warning: -headless is deprecated. Use –headless instead.
    Warning: -nologo is deprecated. Use –nologo instead.
    Warning: -nofirststartwizard is deprecated. Use –nofirststartwizard instead.
    Warning: -accept=socket,host=127.0.0.1,port=8100;urp is deprecated. Use –accept=socket,host=127.0.0.1,port=8100;urp instead.

    y nunca inicia….

    Gracias

  • juanc1550 says:

    Cordial Saludo

    Juan le comento intale openmeetings de una version live dvd me funciona muy bn pero solo me hace falta algo quiero saber como la puedo vincular la direccion donde me funciona mi servidor de openmeetings a un dominio ejemplo openmetings.midomino.com, gracias por la atencion prestada ,quedo atento a comentarios.



Escribe un comentario

Tu dirección de correo electrónico no será publicada. Los campos necesarios están marcados *

Puedes usar las siguientes etiquetas y atributos HTML: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>